birmingham.io

Power adaptors - can someone help me understand this?

Related to my twinkling LED post, according to the specs for the WS2812 LEDs I’m using, if I want to power more than 5 of them (I’m going to need at least 20), I need an external power source from that of the Ardunio.

A quick google search on how to achieve this lead me to learn of the Breadboard Power Supply Module, which then solved another mystery - the purpose of one of the strange devices which I got with my Raspberry Pi starter kit (it was a BPS).

Anyway, so I have a BPS, and I’m eager to have a play with it, but I’m a little concerned about the readings my multimeter is getting off it.

If I understand correctly, I’ve got the ability to choose between 5v and 3.3v based on the location of the jumper pins, so I set about experimenting:

  • I set the jumper to the 3.3v position and took a measurement of 3.29 V - perfect

  • I then set it to the off position and took another measurement, this time it was 0.8 mV (which I guess is as close to off as it needs to be)

  • So finally set it to the 5v position and took my final reading: 16.28 V :confused:

Either I’m reading this wrong, the multimeter is broken, or the BPS is sending too much voltage when the 5v jumper is set.

So I’m really confused by this, and a little scared to go any further because I don’t want to blow my new RGB LEDs.

There is one further piece of information which might help unravel this - I’m using a 12v power supply which I’ve salvaged from an old router to power the BPS. The plug itself has the following info on it:

Am I using the wrong sort of power supply?

Cheers

It’s been a long time since I did any electronics (A Level - and I dropped in 3 months in) but my immediate thought was to just use a resistor. Turns out that (on it’s own) is wrong but this article offers some solutions:

Isn’t that what the BPS should be doing for me? It appears to be supplying a 3.3v supply without issue, but not a 5v.

Have you got a pic of these jumpers?

I’m pretty sure it’s a coincidence that it sounds very like 5 x 3.3 but jumpers scare me.

New photo by Daniel Hollands

Also, I found this. Mine isn’t branded YwRobot, but appears to be exactly the same otherwise.

Nope, I can’t help. What you’ve done looks reasonable to me.
I assume you’d get 0V if you connected the Off pins?

Hang on! What’s that other bank of pins for? I now have no idea what’s going on.

I’ve just found a couple of articles about it:

And have also managed to bust my Arduino in testing it :expressionless:

Long story short, I think using a 12v power supply was too much for it to handle. I should have paid attention to the reading on the multimeter. OH well, put it down to experience and move on. That’s not a mistake I’ll make again in a hurry.

New arduino arriving in the post tomorrow. In the meantime, I need to figure out how to supply power 20 neopixels.

At least you’ve restored faith in your multi-meter :-/

I’ve always disliked power supply with jumpers. Also, you should always protect your circuit with an smd fuse. Did you built this?

Anything in the *mV is no voltage at all. Where on the circuit did you measured the voltage from?

No, it was pre-assembled.

I used the two terminals on the bottom left of the board.

Where is that board? A good image would be great.

New photo by Daniel Hollands
1 Like

I got a replacement Arduino this morning (just a cheap third-party one for £9 from Amazon) and it works fine, so I’m now pretty confident that not only is the other Arduino totally busted, but that the BPS is also busted, and both will be going in the bin.

So I’m now back to solving the issue of powering ther 20 LEDs. After some research I’ve decided to buy an AC to DC Universal Charger Multi-Voltage UK mains Plug Power Adapter Supply (wow, that’s a mouthful :speak_no_evil:).

The 2400mA it can supply should be enough to power both the LEDs and Arduino - what I don’t know, however, is quite how to wire it all together - I’m guessing I need some type of DC jack? (That has to be preferable to cutting the wires open, right?)

I found this post on stackoverflow describing exactly what I want to do, so I’m posting it here for reference:

Although it was suggested in the other thread that I could power the arduino directly from the 5v pin, I don’t like that this skips the regulator, so may opt for the usb approach suggested instead (although I’m open to feedback and other suggestions)

And another with some interesting info:

Another update (sorry), but I’ve been experimenting with the BPS again, and I’m pretty sure that the processed used to step down to 5v is broken (maybe due to a short? I don’t know), but the 3.3v seems to work fine.

Now I’ve got my new power supply I’m able to to choose how many volts I want to send, and near as I can tell, it’s simply passing on whatever voltage it is supplied with - so the adaptor I used before must have been supplying 16v, and thus fried everything (except the LEDs, they survived).

Anyway, while I don’t fully trust it, I may still be able to use it, along with my new power supply, to power the whole rig - I’m going to experiment a little, and hopefully won’t electrocute myself in the process.

Update: It actually worked:

http://imgur.com/fBVFRpj

It’s a little hard to see from the photo, so I’ll try describing what’s going on:

  • I’ve got 5v going into the BPS via my new adaptor, which in turn is being fed into the power rails on the breadboard.

  • Connected to the positive rail is the positive terminal on the LED strip, and connected to the ground rail is the ground terminal on the strip, as well as the ground on the arduino.

  • Additionally, I’m using the USB port on the BPS to feed into the USB on the Arduino.

  • Finally I connected pin 8 on the Arduino to the data terminal on the strip.

The next step is to try with 20 LEDs, but that will involve some soldering, so I’ll try that shortly.

1 Like

Proudly sponsored by Bytemark