macOS Sierra broke Karabiner


(Daniel Hollands) #1

I updated my iMac to macOS Sierra today, and as you can probably tell from the title of this thread, it’s broken Karabiner.

In my specific use case, I used Karabiner with my Ducky One keyboard for three main things:

  1. Swapping the command and option keys
  2. Making the Home and End keys work
  3. swapping the ` \ keys

None of which were working as intended after the upgrade. Bugger.

Anyway, this isn’t a post to bitch about the update (well, it is a little bit - I mean the last update broke TotalFinder), but instead to let you know that I’ve found some workaround - just in case any of you have the same issue:

The solution for the first problem can be found way at the bottom of the issue thread linked to above and involves updating the keybindings via system preferences:

  • Open System Preferences->Keyboard->Modifier Key, then
  • Change Option Key to Command and Command Key to Option

This isn’t any good for people with laptops who use multiple different keyboards (like me), but it’s better than nothing.

The second fix involves creating a ~/Library/KeyBindings/DefaultKeyBinding.dict file and populating it with:

{
  "\UF729"  = moveToBeginningOfLine:;
  "\UF72B"  = moveToEndOfLine:;
  "$\UF729" = moveToBeginningOfLineAndModifySelection:;
  "$\UF72B" = moveToEndOfLineAndModifySelection:;
}

I’ve not figured out the solution to the third problem yet, but I think it’ll have something to do with Karabiner Elements.

Anyway, I hope this helps someone.

UPDATE:

Turns out the third issue is fixable using Karabiner Elements - but this breaks the fix for the first issue, so I’ve solved both via Karabiner Elements with the following config:

{
    "profiles": [
        {
            "name": "Default profile",
            "selected": true,
            "simple_modifications": {
                "non_us_backslash": "grave_accent_and_tilde",
                "grave_accent_and_tilde" : "non_us_backslash",
                "left_option": "left_command",
                "left_command": "left_option"
            }
        }
    ]
}

(Andy Wootton) #2

I want to do this upgrade too but it’s harder. I’ve got a 5 year old Mac running Snow Leopard so I must go through other versions. ‘Everything’ (hardly anything) on the Apple site appears to say it should be a) possible and b) free but when I try, it says my hardware isn’t supported. Haven’t tried very hard yet but I think it was also administered through a Mac Server. Is that going to make my life hard? Are records of licences on the server? I’ve really missed software licensing.

I was amazed how cheap a Mac Server licence is. Do people buy them? It gives you stuff you could probably get free with a lot more work and Apple-fighting. Seems a bargain.


(Marc Cooper) #3

I saw Karabiner was broken in Sierra. I’ve fully embraced The One True Way on this update. It took a few days, but I’m glad to be rid of the overhead of a few utils, tbh.

Other than flux, for which Apple has no equivalent, the only utility I’m running is xtrafinder. Why Apple don’t buy this and be done with it, I’ve no idea. Naked Finder is like punching yourself in the face.

Ah, I also run Moom. But it’s not a deal breaker.


(Steve Jalim) #4

Oh my - xtrafinder. Ever since SIP made my beloved TotalFinder a no-go/less of a sure thing, I’ve been trying to find alternatives. Downloading now.

Also: https://kapeli.com/dash is worth all of the dollarpounds you can throw at it


(Marc Cooper) #5

+1

P.S. hex packages too.